ひといきブログ

技術的な備忘やデジモノレビュー等、ちょっとひといき

VIP(HSRP)間の接続について

長らく更新が途絶えてしまいました。。。

はじめに

ネットワークを構築するとき、各機器の冗長化は当たり前かと思います。
その際、CiscoのL3SWやRTを使用する場合はHSRPを組むことが多いでしょう。
今回はHSRPを組んだ機器間の接続について、実装して確認したのでブログに残そうと思います。

実験した構成

まず物理的な構成は↓の通りです。
f:id:camit:20160327210302p:plain
この状態で、L3SW#1-RT#1間が切れた場合に予備系へ切り替わり、通信が継続できるかを実験しました。
f:id:camit:20160327210310p:plain

次にIPアドレス等、論理構成です。
L3SW間はtrunkポートです。
f:id:camit:20160327210315p:plain

IPアドレス マスク 機器
172.0.0.1 255.255.255.252 PC#1
172.0.0.2 L3SW#1
10.0.0.1 255.255.255.248 L3SW VIP
10.0.0.2 L3SW#1
10.0.0.3 L3SW#2
10.0.0.4 RT VIP
10.0.0.5 RT#1
10.0.0.6 RT#2
10.0.0.9 255.255.255.252 RT#1
10.0.0.10 RT#2
10.0.0.13 255.255.255.252 RT#1
10.0.0.14 PC#2

次にHSRPの設定です。
L3SW側とRT側で、HSRPのグループ番号が違うところが肝です。グループ番号を同じにした場合、同じグループにVIPを2つ持つことになり、下記のエラーメッセージが出力され続け、正常にHSRPが組まれません。

%HSRP-4-DUPADDR: Duplicate address 10.0.0.1 on Vlan100, sourced by xxxx.xxxx.xxxx.xxxx

L3SW#1 L3SW#2
standby 1 ip 10.0.0.1 standby 1 ip 10.0.0.1
standby 1 timers 1 4 standby 1 timers 1 4
standby 1 priority 110 standby 1 priority 100
standby 1 preempt standby 1 preempt
RT#1 RT#2
standby 2 ip 10.0.0.4 standby 2 ip 10.0.0.4
standby 2 timers 1 4 standby 2 timers 1 4
standby 2 priority 110 standby 2 priority 100
standby 2 preempt standby 2 preempt

実験結果

  • 現用系の場合

想定通りに、グループ1はL3SW#1がActive、L3SW#2はStandbyとなり、VIPはL3SW#1が持っている状態となりました。
同様にグループ2はRT#1がActive、RT#2がStandbyとなりました。
なお、グループ1,2ともに、HSRPのハローパケットは緑の経路を通って通信されています。

  • 予備系の場合

L3SW#1とRT#1間が切れた場合、RT#2がActiveとなり、下記のような経路で通信されるのでしょうか。
f:id:camit:20160327210320p:plain
結果は、上図のとおりの経路で通信されました。
RT#1はHSRPを設定しているリンクがダウンしている状態のため、Initとなっていました。
RT#2はActiveとなっており、RT#2から見たStandby系はunknownとなっていました。

まとめ

片方がL3SW、片方がRTという構成で、両機器がそれぞれHSRPを組むという例が見当たらなかったので実験してみましたが、見事にうまくいきました。
あとはアクセスリストを入れてあげれば、実際に企業等で利用できる状態になるでしょう。
今回はHSRPだけでしたが、さらにRT側でSNATなどする場合は、予備系になったときのために、戻りのスタティックルーティングをRTに追加してあげる必要がでてきます。
そちらについてはまた今度ですかね。

CiscoのL3SW買いました!

更新が途絶えてしまいました。^^;
三日坊主もとい、三回坊主にはならなかったので、まあ続いた方です(笑)

さて、業務の方では最近ネットワークばかりに触れていますが、さっぱりすぎて若干辛いです。。。
ということで、勉強用に中古のL3SWを買いました!

買ったのはこれ!
Cisco Catalyst3560-24TS-E
f:id:camit:20160222002320j:plain
中古のCiscoのL3SWを2台買いました(笑)
ただ、やはりGigabitEthernetのSWは高いのでFastEthernetです。
購入はNW工房です^^
nwkoubou.jp
ここは、注文から商品到着まで1日と早かったですね。機会があったら、また利用したいと思います。
また、SWとは別に、オークションでルータを2台落札しました。こちらは今週中には到着するかと。

昨日今日で、L3SWx2、ルータx2で計4台NW機器を購入しました。
とりあえず、今業務で詰まっているところを早期に解決していきたいと思います^^;

静的NATありのAS間BGP接続について

先日仕事でBGPでNATセグメントのルーティングを広告するかを検証したので、備忘の意味を込めて残します。

構成図

f:id:camit:20160207000357p:plain

AS50000にあるPC-Aから、AS40000にあるPC-Bに接続します。また、RT-AでPC-Aの送信元アドレスをNATします。

# 実際はPC-Bは繋がずにL3SW-Bのループバックにpingをして確かめました^^;

下記にそれぞれのアドレスを示します。

IPアドレス サブネットマスク V-LAN
PC-A 110.232.40.1 255.255.255.252 -
RT-A(PC-A側) 110.232.40.2 255.255.255.252 10
RT-A(loopback) 110.232.40.5 255.255.255.252 -
RT-A(WAN側) 110.232.40.9 255.255.255.252 11
L3SW-B(WAN側) 110.232.40.10 255.255.255.252 12
L3SW-B(loopback) 110.232.40.13 255.255.255.252 -
L3SW-B(PC-B側) 110.232.40.17 255.255.255.252 13
PC-B側 110.232.40.18 255.255.255.252 -
NAT 110.10.10.0 255.255.255.0 -

設定

改めて確認したいことは、RT-AのBGPのnetworkにNATセグメントを記述したら、RT-Aがルーティングを覚え、L3SW-Bに広告するかどうかです。
さて、L3SW-Bの設定です。
# 実機がないので、とりあえずは基本的な部分とルーティングとBGPだけです^^;
まず、インターフェースです。

interface Loopback0
  ip address 110.232.40.13 255.255.255.252
interface Gigabitethernet0/1
  switch port mode access
  switch port access vlan 12
  duplex auto
  speed auto
interface Gigabitethernet0/2
  switch port mode access
  switch port access vlan 13
  duplex auto
  speed auto
interface Vlan 12
  ip address 110.232.40.10 255.255.255.252
interface Vlan 13
  ip address 110.232.40.17 255.255.255.252

デフォルトルートはPC-Bの方を向くので、

ip route 0.0.0.0 0.0.0.0 110.232.40.18

BGPは、

router bgp 40000
  router-id 110.232.40.13
  network 110.232.40.13 mask 255.255.255.255
  network 110.232.40.16 mask 255.255.255.252
  neighbor 110.232.40.9 remote-as 50000
  neighbor 110.232.40.9 timers 5 15
  neighbor 110.232.40.9 advertisement-interval 1

L3SW-Bの設定は以上です。
次はRT-Aの設定です。インターフェースは次の通りです。

interface Loopback0
  ip address 110.232.40.5 255.255.255.252
interface Gigabitethernet0/1
  switch port mode access
  switch port access vlan 11
  duplex auto
  speed auto
interface Gigabitethernet0/2
  switch port mode access
  switch port access vlan 10
  duplex auto
  speed auto
interface Vlan 10
  ip address 110.232.40.2 255.255.255.252
interface Vlan 11
  ip address 110.232.40.9 255.255.255.252

デフォルトルートはPC-Aを向くので、

ip route 0.0.0.0 0.0.0.0 110.232.40.1

BGPは、

router bgp 50000
  router-id 110.232.40.5
  network 110.232.40.5 mask 255.255.255.255
  network 110.10.10.0 mask 255.255.255.0
  neighbor 110.232.40.10 remote-as 40000
  neighbor 110.232.40.10 timers 5 15
  neighbor 110.232.40.10 advertisement-interval 1

RT-Aの設定は以上、だと思ってました。。。

上記設定の結果

NATセグメントのルーティングは、RT-Aは覚えてくれませんでした。当り前?なんですかね。
結論として、明示的にルーティングを追加することで、RT-Aで覚え、L3SW-Bで学習してくれました。

ip route 110.10.10.0 255.255.255.0 Gigabitethernet0/2

HandDialerのバグ??⇒どうやら違うようでした^^;

SmartWatch3とXperiaZ3Compactを利用して早1ヶ月近くとなりますが、ひとつバグ?と思われるような事象が発生しています。。。

それは、着信した電話にでた瞬間に電話が切れることです。最近何回か連続で同事象が発生し、ようやっと気付きました^^;

いまいち原因の切り分けができていないのですが、SmartWatch3+Xperia+オーテクのBluetoothイヤホンで使用した時は、電話にでてイヤホンで通話できたのを覚えています。なので、もしかしたらアプリケーションが邪魔しているのかなーと考えています。

その時は、唯一SmartWatch3に入れている電話アプリであるHandDialerを、まだ入れていなかったような気がします。

とりあえず、来週はHandDialerを削除した状態で過ごして、結果をご報告したいと思います。

 

HandDialerをアンインストールして1週間過ごしてみましたが、やはり着信に出たらその瞬間に切れました。しかし、試しに固定電話からかけてみると、普通に出ることができました。

どうやらスマホからの着信に限定される現象のようです。

XperiaZ3Compact、もしくは電話アプリ(デフォルト)のバグのようです^^;

(2016/01/31追記)

SmartWatch3を使ってみて

SmartWatch3を購入して早3週間、毎日付けているので、ここらで簡単に使ってみた感じを以下の観点に基づいて書いてみたいと思います。

  1. 通知への気づきやすさ
  2. 電池の持ち
  3. ウォッチフェイス
  4. 対応するアプリ

1.通知への気づきやすさ

まず、通知に気付くかどうかですが、ほとんどは気付きます。たまに振動していないのか、私が鈍いのかわかりませんが、気づきません。。。

また、LINEの無料通話はスマホの通知領域に出ないためか、スマートウォッチでも気づくことができません。こればっかりはLINE側の対応を待つしかありませんね。

電話に関してはHand Dialerというアプリを入れているんですが、たまに着信に反応してくれません(;_:)

Hand Dialer for Wear
開発元:JokerXT
価格:無料(アプリ内購入あり)

2.電池の持ち

仕事中はあまり触らないためか、3日位持っているような気がします。帰宅後に30%切っていたら充電する感じです。それでも1時間くらいでほぼ満充電になるので、あまり困ってはいません。

1週間持つとかよりは、逆にこれくらいの方が、忘れてて電池切れたなんてことがないのでいいと思います。

3.ウォッチフェイス

いいのがありません。。。

最初はデフォルトで入っていたSportsを利用していましたが、せっかくだしということで探して入れてみましたがいいのがありませんね。

今はGoogleがブランドと提携して公式に提供したウォッチフェイスの1つを利用しています。

時計を自分スタイルに - Google Play の Android アプリ

Time Will Come
価格:無料

4.対応するアプリ

まだまだできることは少ないスマートウォッチですが、それなりに役立ちそうなアプリはあり、いくつか入れているものをご紹介します。

 

Wear Audio Recorder
開発元:BinomV
価格:無料(アプリ内購入あり)

 

普段使うことはないかもしれませんが、打ち合わせ等のときに役立つかと思います。スマホ本体に保存されるので、使い勝手もいいと思います。

 

PixtoCam for Android Wear
開発元:Pixtogram
価格:¥199

 

遠隔でスマホのカメラを使えて、スマホの方でもカメラ画面が開かれず、かつシャッター音もならないので、静かな場所で写真を撮るのに向いているかもしれません。

 

Photo Gallery for Android Wear
開発元:appfour
価格:無料(アプリ内購入あり)

 

写真閲覧アプリです。PixtoCamで撮った写真をすぐ確認するのに便利です。

 

とりあえずは便利だと思ったアプリをご紹介しましたが、皆様もこれはいいというものがありましたら、挙げていただけるとありがたいです。

今週(1/3週)の世情とSECCON

年始に書いた目標がさっそく破られそうな予感がしています(笑)

って笑いごとではないですけど。。。

 

1/3週のまとめ

今週は各企業仕事始めの週だったのではないでしょうか。

かくいう弊社も4日から仕事が始まりました。

が、やはりやる気はなかなかでないですね(笑)

 

電力自由化で各社のプランが発表されましたね。

東京ガスにすると電気とガスの料金を一括で支払えて便利かなーと、軽く考えたりもしましたがどうなんでしょうか。

やはり面倒ではありますが、ここ一年の電気使用量を振り返って各社シミュレーションするのが一番なんでしょうね。。。

 

SECCON

セキュリティコンテスト、略してSECCONに参加しないかと、会社の先輩に誘われ、OKしました。

ただ、中身も分からなければ、暗号等に明るいわけではないので、これから勉強していきます。

また、SECCONに参加する人が使用できる言語ランキングなるものがあって、CやBashの他、Pythonが使える人が多かったので、Pythonも勉強していこうかと思います。

 

年始の目標でScalaやるって書きましたけど、Pythonに変更かなーと考えたりしてます(^_^;)

2016年のTODO

新年あけましておめでとうございます。

年を食うたびに、1年が経つスピードが早くなっている気がします(笑)。

昨年は、無意味に社会人生活を過ごして、何も生み出さず成長も少なかったように思えます。目標も立てずに過ごしていたこともあるかもしれません。

なので今年は目標を立てます!TODOです!

 


 目標その1

まず、昨年は本ブログを立ち上げたのにもかかわらず、全く更新していませんでした。放ったらかしでした。リソースの無駄遣いです。

なので、今年はできれば週1、無理でも2週に1回は更新します!

 

目標その2

 2つ目は資格の取得です。つい先日ネットワークスペシャリストを受験したのですが、ほとんど勉強せず当然のごとく落ちました。。。

仕事でネットワーク周りもやっていたので、もしかしたらいけるかなーって思ったのが間違いでした(・ω<)

今年は資格取得の年にもしたいので、様々な資格を取って行きたいです。

具体的には、春にセキュリティスペシャリスト、秋にネットワークスペシャリスト、他OracleMasterBronze、CCNAを取得します!

 

目標その3

 3つ目は健康です。昨年初めて人間ドックを受けました。特に問題はなかったのですが、後3年で30歳ということも考えると、そろそろ身体を動かす習慣も付けていきたいところです。

私の性格として、損を意識できないと動けないので、今年はジム通いをして身体を鍛えます!

# お金見合いですが。。。^^;

 

とりあえず通年での目標はこんなところでしょうか。

あとはScala+PlayでWebアプリケーションを作りたいですね。

 

本年もよろしくお願いいたします。